Aspire ES1-131 Kein Dualboot mit Windows geht.

Dieses Thema im Forum "Linux" wurde erstellt von canned70, 12. Dezember 2016.

Schlagworte:
  1. #1 canned70, 12. Dezember 2016
    Zuletzt von einem Moderator bearbeitet: 12. Dezember 2016
    Hallo zusammen,
    ich habe hier ein "Aspire ES1-132" mit Windows 10.
    ICh möchte paralell zum Windows ein Linux Derivat installieren, die Installation von z.B. Ubuntu 16.10 64Bit funktioniert auch prima, leider wird aber immer die Bootreihenfolge überschrieben, so das nur noch das Booten von Windows möglich ist..
    Im Uefi des "es1-132"finde ich kein Option den Ubuntu Bootloader zu "zertifizieren" ("EFI File Boot 0: Yes").
    Hat einer von euch eine Idee wie ich hier weiterkommen kann?
    Danke und viele Grüße
    Marc
     
  2. Hallo,
    wo ist das Problem.
    SecureBoot im BIOS deaktivieren und by by, Windows.
    Wenn der Windows Bootlader kein Linux startet, tut es der Linux Bootlader mit Windows auch nicht.
    Jedenfalls meistens.

    Kleiner Tip.
    Dazu das Supervisor Passwort vergeben. Nach der Aktion nicht vergessen, das PW wieder zu löschen.

    Gruß
    Mc Stender


    Ps.: Einige (Neuere) Linux-Versionen wurden zertifiziert = werden vom Windows aus gestartet.
     
  3. Wenn das so einfach wäre...
    Auch mit gesetztem Supervisor Password lässt sich "Secure Boot" nicht soweit deaktivieren das ich im "MBR" Modus installieren könnte, Windows erstellt beim installieren immer die GPT Partitionierung.
    Was an sich ja nicht schlimm ist und auch mit einem aktuellem 64Bit Linux funktioniert, bzw. funktionieren sollte.
    Auch vom Windows aus wird mir die Linux Installation genau einmal angeboten, so dass ich sie über diesen Umweg booten lassen kann, beim nächsten reboot ist diese Möglichkeit dann auch wieder überschrieben.
    BTW. Auf dem Laptop ist die "Bios" Version 1.08 vom 23. November 2016 installiert.
     
  4. Moin moin,
    vielleicht habe ich mich nicht klar ausgedrückt.
    Ich habe das Supervisor Password gesetzt und SecureBoot im Boot Menü auf "Disable" gesetzt.
    Beim installieren von Windows 10, auf einer neuen SSD will Windows im GPT Mode installieren. Wenn ich die Festplatte vorbereite, mit MBR und entsprechenden Partitionen, dann kommt beim installieren eine Warnmeldung das zwingend eine GPT benötigt wird.

    Ich denke das ich in dem UEFI von dem "Aspire ES1-132" SecureBoot nicht komplett deaktivieren kann, oder ich habe die richtige Option noch nicht gefunden.

    Generell will ich UEFI ja auch nicht abschalten, was ich gerne erreichen möchte ist ja ein DualBoot mit aktiviertem SecureBoot.
    Mein Problem ist ja, dass die Option das zweite System zu booten in der EFI-Partition erstellt wird und auch funktionsfähig ist,
    die Reihenfolge der zu bootenden Systeme aber immer zurückgesetzt wird auf 1.Windows, 2.USB,3.xxx,4.xxx
    Es entsteht fast der Eindruck das diese Boot-Order im NVRAM des Laptop hinterlegt ist und dann beim reboot des Systems die Boot-Order auf der Festplatte überschreibt.
    Was mir fehlt (oder ich nicht finde), und was offensichtlich normalerweise bei ACER im UEFI vorhanden ist, ist die Möglichkeit sozusagen die "shimx64.efi" von Linux zu zertifizieren.

    z.B. aus dem Ubuntu Wiki:
    der Abschnitt Acer Rechner:

    • "EFI File Boot 0: Yes"
    • "Select an UEFI file as trusted for executing"

    Grüße
    Marc
     
  5. Hallo,
    ich denke, so, wie Du es gerne möchtest, geht es nicht.
    Also Deine Win 10 Lizenz ist auf UEFI geblockt (kam mit dem Lappy mit).
    Deine Festplatte enthält einen Teil vom BIOS um schnell starten zu können (Halt UEFI UND GPT) .
    Damit startet immer der Windows Bootlader oder dein Datenträger / Windows tut´s nicht mehr.

    Unter MBR war das deutlich einfacher .....

    Einzigste Abhilfe ist ein "Zertifizierter" Bootloader von Linux.
    Den würde der Windows Bootlader erkennen und starten.

    Dumm und Blöde.... OK.
    Danke MS + Intel.

    Gruß
    Mc Stender
     
  6. Hallo,

    ich kenne das Linux Derivat nicht, ist auch nur für Profinutzer gedacht.
    Das Problem liegt am Acer BIOS.
    Ich kann ohne Probleme beim Nexoc S516II Ubuntu neben Windows 10 64 Bit im GPT Partitionstil (Secure Boot deaktiviert) Installieren.
    Installation vom USB-Stick aus, erstellt mit Rufus - Erstelle bootbare USB-Laufwerke auf einfache Art und Weise
    Beim Start des Notebooks kann ich auswählen, mit welchen Betriebssystem ich starten möchte.

    MfG Olaf
     
  7. Hallo,
    Für mein Verständniss erfüllt ein aktueller Ubuntu 64Bit Bootloader alle Voraussetzungen der "Secure Boot" UEFI-Spezifikation, das kann also kein Grund sein.
    UEFI sitzt ja logisch "vor" dem OS, hier kann man nicht Windows die Schuld geben.
    Microsoft und Intel haben zwar bei der Spezifikation der Standards mitgemischt, aber es gibt ja auch UEFI Implementierungen bei denen es funktioniert zwei OS die die Specs erfüllen, parallel zu betreiben.
    Ich sehe hier eher Acer oder vielleicht "InsydeH20" in der Verantwortung.